Featured

Grande Rede Empresarial no GNS3 – intro

Há algumas semanas eu venho praticando meu conhecimento em redes pois estou estudando atulmente para passar no exame CCNA 200-125, Eu ainda não completei o curso estou no 4° e último modulo do CCNA R&S pelo NetAcad tenho aulas presencial no Senac tito em São Paulo.

Grande Rede Empresarial no GNS3 – intro
Grande Rede Empresarial no GNS3 – Part1

Bom, o que primeiro começou como uma pequena rede empresarial logo cresceu para um grande rede com Campus, DMZ, Data Center, Sites remotos além de dispositivos Cisco adicionei outros fabricantes como Juniper, F5, Mikrotik e Extreme. Durante as semanas em que eu vim configurando essa topologia eu encontrei vários problemas tanto de erros de configuração e alguns problemas causados pelo GNS3. Os TSHOOTS foram vários o GNS3 é uma ótima ferramenta mas ainda não está 100% a comunidade se esforça muito e há atualização frequentes para corrigir problemas de emulação, tive algumas dificudades em fazer o link to GNS3 com o Windows Server 2012 que estou virtualizando pelo Vmware no final era o firewall do Windows que estava a ativado, não consegui adicionar etherchannel possivelmente não seja um erro no GNS3 e sim da IOS que estou utilizando para os switches L3, atualmente os containers “dockers” estão causando problema na VM do GNS3 após iniciar uma docker há um conflito com a VM eu não descobri como corrigir essa erro fiz algumas buscas mas sem sucesso. Levei um bom tempo pra deixar essa topologia funcionando do jeito que planejei atualmente eu parei de adicionar outros dispositivos e irei descrever o passo a passo e as tecnologias que eu utilizei até aqui.

A empresa tem um nome fictício de Falconbird.inc. Você pode ver a topologia completa na imagem abaixo.

Topologiagns3

Os dispositivo são todos virtualizados e comsomem muita memória e processamento então caso você queira reproduzir essa topologia segue abaixo as configuração do meu PC.

PC-Hardware
CPU: AMD FX(tm)-6300 Six-Core Processor speed: 3.50 GHz
RAM: 16GB 2x 8192 MB DDR3 1600Mhz

Softwares
Windows 10, Windows Server 2012
GNS3 2.1.6 com GNS3VM
VMware Workstation
Kiwi Syslog, Observium, Asdm.

A topologia e hierárquica com switches de acesso, distribuição, core um roteador ASBR, um firewall Asav conectando a Internet pública e o Mikrotik como backup para Internet pública formando todo o backbone do rede, DC Data Center consite em um servidor Windows server 2012 e o Observium que estou utilizando para o monitoramento da rede ele está sendo emulado pelo qemu pois tive problemas com o container como mencionei anteriormente os container estão causando conflito com a VM do GNS3, A DMZ tem o F5 fazendo o loading balance dos três servidores web que na verdade são três dockers WordPress o Ubuntu para acesso ssh e o Firefox e para o testes no servidores web, A área 2 que tem um switch L3 Juniper, 5 sites remotos conectados no ASBR o roteador de borda os três sites remotos no EIGRP AS 101 estão conectados via tunnel DMVPN com ipsec as área OSPF 51, 52 via tunnel GRE com IPSEC.

Grande Rede Empresarial no GNS3 – Part1

Grande Rede Empresarial no GNS3 – Part 1 – Access Layers

Esta é a primeira parte da rede empresarial que consiste em dois switches de distribição e quatro switches de acesso e os seus despositivos finais. As imagens que e estou abaixo.

Switches de acesso IOS: c3640-ik9o3s-mz.124-25b.image
Docker : gns3/ubuntu

accesslayer1

Os computadores estão associados as VLANs 10,20,30,40,99 nativa e para gerenciamento dos switches com o subrede de 172.16.99.0/24.

Rede                                        Default Gateway        SVI vISO-3, vIOS-4
VLAN 10 : 172.16.10.0/24 | DGW 172.16.10.254 | SVI : 172.16.10.253 e 252
VLAN 20 : 172.16.20.0/24 | DGW 172.16.20.254 | SVI : 172.16.20.253 e 252
VLAN 30 : 172.16.10.0/24 | DGW 172.16.30.254 | SVI : 172.16.30.252 e 253
VLAN 40 : 172.16.40.0/24 | DGW 172.16.40.254 | SVI : 172.16.50.252 e 253
VLAN 50 : 172.16.50.0/24 | DGW 172.16.50.254 | SVI : 172.16.50.253 e 252

Vamos iniciar a confiuração do switch SW1 as interfaces fa0/2 e fa0/3 devem estar em modo trunk e todas as restantes asinaladas a Vlan 10.

  1. Switch SW1 Configuração.

O GNS3 não emula switch cisco estou usando o roteador c3640 com o slot NM-16ESW. O roteador irá funciona como um switch.

sw1slot

 SW1#!Entre no VLAN database com o comando abaixo
 SW1#vlan database
 SW1(vlan)#vlan 10 name IT
 SW1(vlan)#!VLAN99 para gerenciamento e untagged vlan
 SW1(vlan)#vlan 99 name NATIVE
 SW1(vlan)#exit
 SW1#conf t
 SW1(config)#ip routing
 SW1(config)#interface range fastEthernet 0/4 - 15
 SW1(config-if-range)#description ##### INTERFACE ACCESS #####
 SW1(config-if-range)#switchport mode access
 SW1(config-if-range)#!Adicione as interfaces na VLAN10
 SW1(config-if-range)#switchport access vlan 10
 SW1(config-if-range)#spanning-tree portfast
 SW1(config-if-range)#exit
 SW1(config-if-range)#!Configurar as interfaces em modo Trunk
 SW1(config)#interface range fastEthernet 0/2 - 3
 SW1(config-if-range)#no shutdown
 SW1(config-if-range)#no cdp enable
 SW1(config-if-range)#switchport
 SW1(config-if-range)#switchport trunk encapsulation dot1q
 SW1(config-if-range)#switchport mode trunk
 SW1(config-if-range)#switchport trunk native vlan 99
 SW1(config-if-range)#description ##### TRUNKING #####
 SW1(config-if-range)#exit
 SW1(config)#!Criando a interface vlan99 para gerenciamento
 SW1(config)#interface vlan 99
 SW1(config-if)#ip address 172.16.99.10 255.255.255.0
 SW1(config-if)#description ##### MGMT #####
 SW1(config-if)#exit
 SW1(config)#ip default-gateway 172.16.99.254
 SW1(config-if)#exit
 SW1#wr

Implementando SSH e Segurança.
Somente a rede 172.16.10.0/24 deve acessar as VTY para acesso SSH.

 SW1(config)#ip domain-name SW1
 SW1(config)#username admin password cisco
 SW1(config)#crypto key generate rsa 
 SW1(config)#1024
 SW1(config)#ip ssh authentication-retries 3
 SW1(config)#ip ssh time-out 90
 SW1(config)#ip ssh version 2
 SW1(config)#ip access-list standard 1
 SW1(config-std-nacl)#1 permit 172.16.10.0 0.0.0.255
 SW1(config)#line vty 0 5
 SW1(config-line)#! Permitindo somente a rede 172.16.10.0/24 acessar a VTY
 SW1(config-line)#access-class 1 in
 SW1(config-line)#transport input ssh

Implemente essa configuração em todos os Switches!

Para referência o config.txt dos switch.

sw1.txt ,  sw2.txtsw3.txt , sw4.txt

Seinfeld: The Complete Series

4117209_G

All episodes from all seasons x264 DVDRip + all the extras from all seasons, please seed.

Seinfeld is an American television sitcom that originally aired on NBC from July 5, 1989, to May 14, 1998, lasting nine seasons, and is now in syndication. It was created by Larry David and Jerry Seinfeld, the latter starring as a fictionalized version of himself. Set predominantly in an apartment block on Manhattan’s Upper West Side (but shot mainly in Los Angeles), the show features a host of Jerry’s friends and acquaintances, in particular best friend George Costanza, former girlfriend Elaine Benes and next door neighbor, Cosmo Kramer.

Seinfeld was produced by Castle Rock Entertainment and distributed in association with Columbia Pictures Television and Columbia TriStar Television; Sony Pictures Television has distributed the series since 2002. It was largely co-written by David and Seinfeld with input from numerous script writers, including Larry Charles, Peter Mehlman, Gregg Kavet, Andy Robin, Carol Leifer, David Mandel, Jeff Schaffer, Steve Koren, Jennifer Crittenden, Tom Gammill, Max Pross, Charlie Rubin, Marjorie Gross, Alec Berg, Elaine Pope, and Spike Feresten.

A critical favorite, commercial blockbuster and cultural phenomenon, the show led the Nielsen ratings in its sixth and ninth seasons and finished among the top two (along with NBC’s ER) every year from 1994 to 1998. In 2002, TV Guide named Seinfeld the greatest television program of all time.

Size 51.32 GB

Download Torrent here > 1419078920_Gnome-Document-Save-48